サポート - IGESを読み込む

1. 新規で読み込む場合

「ファイル」メニューの「開く」(もしくは「開く」アイコン)をクリックし、「ファイルの種類(T:)」を「モデルファイル」から「IGESファイル (*.igs)」に切り替えます。

ファイル名をクリックで選択して、「開く」ボタンを押します。

 

2. 現在のファイルに挿入する場合

「挿入」メニューの「IGESファイル...」をクリックします。

ファイル名をクリックで選択して、「開く」ボタンを押します。

 

ファイルを開くダイアログでファイル名が表示されない場合

IGESファイルは、通常.igsというファイル拡張子ですが、出力側のCADによっては、.igesとなっている場合があります。このような場合、Windowsのエクスプローラーから、名前の変更により、ファイルの拡張子を.igsに変更してください。

 

正しくファイルが読み込めない場合の設定

IGESファイルには、そのサブセットや出力側のCADの特性により、さまざまな表現方法が流通しています。 
Part Modelerでは、さまざまな出力に対応するため、強力な読み込み時のオプションを提供しています。

読み込み前に、ツールメニュー → オプションシステムから、ダイアログを開いてください。その中のトランスレーションタブには、下記のオプションがありますので、これらのオプションを変更してお試しください。

この中で、経験上、最も効果的なオプションは、ヒーリングBREP読み込みの組み合わせです。読み込みに問題が発生する場合、下記のポイントを参考に、設定を変更してみてください。

  • 出力側のCADがソリッドCADの場合は、ヒーリングのチェックは外し、BREP読み込みのチェックを入れた方が良いようです。
     
  • サーフェスCADまたはハイブリッドCADの場合は、ヒーリングのチェックを入れて、BREP読み込みのチェックを外した方が良いようです。
     
  • いずれにおいても、正しい結果とならない場合、両方のチェックを入れる、もしくは外すかして、お試しください。
     
  • サーフェスCADやハイブリッドCADの場合は、CADの特性上、一体のソリッドボディとして読み込まれない場合があります。
    このような場合では、サーフェスの集合として読み込まれますので、面抜けやねじれが発生する場合があります。ヒーリング機能により、できる限りの修正は行ないますが、元の形状から変形する恐れがある場合や、IGESファイル内に矛盾した要素が存在する場合もありえます。このような場合、出力側のCADなどで、出力設定を変更してみてください。
     
  • IGESファイルは基本的にサーフェスの集まりです。(IGESのソリッド要素はBREPと呼ばれています。) サーフェスの集まりで、開いた形状(一体のソリッドボディとして閉じた形状でない場合)は、個々のサーフェスが膨大な要素数となって入力される可能性があります。このような場合、Part Modelerの動作が重くなったり、不安定になる可能性があります。
    動作に極端に影響を及ぼす場合は、出力側のCADにて出力設定を変更するか、必要な要素だけに間引いた上で、再出力を行なってみてください。

 

出力側のCADについて

出力側のCADが不明の場合、それらのヒントを見ることができます。 IGESファイルはテキスト形式ですので、メモ帳などのテキストエディタで内容を確認してみてください。

以下の例は、Part Modelerから出力されたIGESファイルをメモ帳で開いたものです。この中のヘッダー部に、「Part Modeler」の文字を見ることができます。(ただし、複数のCADを経由したり、別のトランスレータを経由したりした場合、最終的に使用されたソフトウェアの情報となりますので、参考としてご覧ください。)

 

戻る

 

タグ: アイジェス JAMA-IS IS